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Foreword

 

Nowadays, three-dimensional computer graphics and digital technologies seem to
have relegated traditional illustration to infrequent uses. That’s a shame. For sure,
photo-realism and cool digital effects have an important role to play. But traditional
illustration has much to offer too. Indeed, through the years, professional illustrators
have developed many techniques that they commonly use to convey their subject
clearly. By combining these techniques with the appeal of artistic rendering, they are
able to create images that are both clear and visually appealing.

Inklination FineArt 3D is our way to bring traditional pen-and-ink illustration to 3D
computer graphics. With this tool, it is possible to create traditional illustrations from
3D CAD models. We made two important decisions when we designed this product:
(1) that it would be a plug-in renderer, rather than a stand-alone product, and (2) that,
when faced with the choice, we would emphasize rendering quality over rendering
speed.

The first decision has two important consequences. First, the many users of Quick-
Draw 3D-savvy applications can quickly start working with FineArt 3D, without hav-
ing to learn a new 3D environment. Second, we can deliver this product as a low-cost
add-on, rather than a more complex, and therefore more expensive, application. 

The second decision influences the way you work with FineArt 3D. Indeed, complex
3D models may take a little while to render; but we think that the result is worth it.

The release of Inklination FineArt 3D would not have been possible without the help
of many individuals. Inklination would like to thank Taweewan Siwadune and Jeremy
Salesin. We are also very grateful to Richard Diehl and Robin Landsbert, and all our
beta testers, including Michael Leckman, Barry Maggert, Robert Pederson, and CJ
Shumate. The pen-and-ink technology was invented in the Department of Computer
Science and Engineering at the University of Washington, by a very dynamic group of
people that included David Salesin, Michael Salisbury, Sean Anderson, Ronen Barzel,
and Georges Winkenbach.

Happy rendering,

Georges Winkenbach, Ph.D.
President
Inklination, Inc.

 

For more information about Inklina-
tion and other exciting illustration
products, visit our Web pages at
http://www.inklination.com.





               
Getting Started

System Requirements
Inklination FineArt 3D (thereafter referred to as FineArt 3D) has the following minimum
system requirements:

• A Macintosh computer with a PowerPC processor (PPC 603 or faster recommended).
• Mac OS 8.0 or newer.
• QuickDraw 3D 1.5.4.
• A client application that support QuickDraw 3D plug-in renderers.
• Enough memory to run the host application with an extra 10 to 20 MB left for 

QuickDraw 3D.
• A display with thousands or millions of colors.

Notes
1. Quickdraw 3D 1.5.4 is bundled with QuickTime 3, which can be downloaded free of 

charge from Apple’s Web site at http://www.apple.com/quicktime.

2. The amount of memory that FineArt 3D requires depends on the complexity of the
3D model, the size of the rendering window, and whether shadows are also rendered.
Several more megabytes of memory may be required for rendering complex and
large images.

3. Rendering high-resolution pen-and-ink images requires applications that support
Inklination’s FineRes™ technology. As of February 3rd, 1999, Microspot has pledged
support for FineRes with 3D World 3.1 due out soon. (For a most up-to-date list of
application supporting FineRes™, check our Web site at http://www.inklina-
tion.com.

Installing Inklination FineArt 3D
If you downloaded FineArt 3D from the Internet
Depending on what Internet browser you are using, and how it is setup, you may end up
with one of three items: a folder named “Ink_FineArt 3D folder,” a binhex file named
“Ink_FA3D_10.hqx,” or a self-extracting archive named “Ink_FA3D_10.sea.”

If you have the folder, you are ready to install and you can proceed to Section Easy
Installation with the Installer below. 

If you have a binhex archive, you can use a utility such as Aladdin Systems StuffIt
Expander™ or MindVision Software MindExpander™ to decode the binhex file and
obtain a self-extracting archive. 

Finally, if you have the self-extracting archive, you can simply double-click on it to run
it like an application. You will be prompted for a location where to save the extracted
3 Getting Started



                   
files. When the extraction is complete, you will have a folder named “Ink_FineArt 3D
folder.”

Easy Installation with the Installer
The easiest way to install FineArt 3D is to double-click on the Installer application and
follow the instructions. Note that the installer will quit all currently running applica-
tions, so you should save your work first. 

Registering Inklination FineArt 3D
About the Trial version
The trial version of FineArt 3D is fully functional; but it prints a “demo” watermark on
every rendering. To eliminate this watermark, you must buy a registration key from
Inklination. As a registered user, you will also be able to buy future upgrades of this
product at a special price.

How to register
To register FineArt 3D you first need to purchase a registration key from Inklination.
This can most conveniently be done on-line by visiting Inklination’s home page at
http://www.inklination.com.

Once you have a registration key, bring up the Renderer Options dialog (see Section
“Fine Art 3D Rendering Options” on page 12). Enter your name, customer key and reg-
istration key in the corresponding fields, and click the Register button. That’s it! You
now have a fully enabled copy of FineArt 3D.

Technical support
Technical support is available on-line from Inklination’s Web pages at http://www.inkli-
nation.com. Technical support is also available by phone and fax, from Monday through

Double-click on Installer to install Inkli-
nation FineArt 3D on your startup drive
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Friday from 9:00AM to 5:00PM Pacific time. Please, have your customer key ready when
you call us, or write it on you fax.

Technical Support:

Phone (604) 608-2649
Fax (604) 608-6644 Attn: Technical Support
E-mail support@inklination.com
Mail 1730 Pendrell St, Suite 210

Vancouver, BC V6G 3A3
Canada
5 Getting Started



                  
What’s New

Version 1.4
Version 1.4 is significantly speedier, up to twice as fast depending on the model and ren-
dering style. We’ve also added a feature that makes it possible to generate high-resolu-
tion images with some applications that do not support our FineRes technology. Finally,
we’ve also corrected a number of small bugs.

Version 1.3
We decided that an and illustration program should have an elegant user interface. So,
for version 1.3, we upgraded the UI. It is now attractive; but it hasn’t lost its simple func-
tional layout. Version 1.3 is also optimized so that applications that render large images
by tiling several horizontal bands will work significantly faster. This new feature is espe-
cially useful with Microspot’s 3D World. Finally, this new version also fixes a bug that
would cause the renderer to sometimes freeze when a large object hides another object
containing many small polygons.

Version 1.2
Version 1.2 brings many improvements:

1. FineArt 3D is now fully compatible with MetaCreations’ Infini-D 4.5.

2. We fine-tuned the crosshatching algorithm and the strokes. The strokes are now
spaced closer together in light areas. These changes should yield better results when
using the default ‘Thin’ stroke thickness.

3. We fine-tuned the outline strokes. Outlines now look smoother, resulting in finer
illustrations.

4. Polygons and shapes assigned the ‘edges’ fill-style are now rendered as outlined only.
This is useful for applications such as 3D World that use the ‘edges’ fill style for grids.

5. A bug that caused incorrect shading with spot lights has been fixed.

6. A bug that caused spurious outline edges in VectorWorks, with orthographic cam-
eras, has been fixed.

7. A bug that would cause the renderer to crash, most notably with Infini-D, has been
fixed.

Version 1.1
Version 1.1 brings two new features. They are Special Lighting Styles, and Custom Col-
ors. Special Lighting Styles consists of three new illumination models, High Contrast,
Overexposed, and Bright Sun. Their aim is to make it easier to create elegant pen-and-
ink images from 3D models that have been conceived for photo-realistic rendering.
These lighting styles are described in detail in Section “Lighting styles” on page 14. Cus-
tom Colors allows you to choose any color for the paper (background) and ink. It’s
described in Section “Custom colors” on page 16.
What’s New 6



  
Another important change in version 1.1 is the use of temporary memory. Until now,
FineArt 3D used the application’s memory. From version 1.1, it uses temporary memory
instead. In most cases, you should not notice the difference. However, if you run out of
memory, the remedy is now different. See Section “Problem: frequent blank renderings”
on page 24 for the new memory-usage directives.

Version 1.1 also includes a number of improvements and bug fixes. Most of these
improvements, as well as the new features, are the direct result of customer feedback.
Please, keep your comments coming our way, so that we may continue refining this
product.
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Rendering with FineArt 3D

What Is Inklination FineArt 3D
FineArt 3D is three things at once:

• A pen-and-ink renderer – it uses a new, patented technology to create images that 
resemble traditional pen-and-ink illustrations.

• A plug-in renderer for QuickDraw 3D – as such, it requires both QuickDraw 3D and 
a host application that knows how to use plug-in renderers.

• A non-interactive renderer – depending on the speed of your computer, the complex-
ity of the 3D model, the rendering options that you have selected, and the size of the 
rendering window, FineArt 3D can take from a few seconds to several minutes to gen-
erate an image.

These three characteristics, as well as the host application, have some implications on
the way FineArt 3D is used. In the next few section, we’ll examine how FineArt 3D is
used from some of the most common QuickDraw 3D host applications. In each case,
we’ll examine how to render with FineArt 3D, how to open the Renderer Options dialog,
and some of the pitfalls to look for.

Using FineArt 3D with Microspot 3D World
To render with FineArt 3D:
1. Choose Renderer Options in the Palettes menu to open the Renderer Options pal-

ette.

2. In the Renderer Options palette, click on the Renderer pop-up menu, and select 
FineArt 3D. 

To open FineArt 3D’s Options dialog:
Continuing from step 2 above, click on the Options button in the Renderer Options pal-
ette.

Known Issues
• If you are using 3D World 3.0, you should turn off the grid before rendering with 

FineArt 3D.
• You may find the Interactive module, which is part of the optional Pro-Pack family of 

plug-in modules for 3D World, very useful. It automatically switches to the Interactive 
renderer when an object is manipulated, and then re-renders with FineArt 3D. 
Another very useful module is Use Offscreen, which reduces the number of redraws.

Using FineArt 3D with Diehl Graphsoft Minicad 7
To select FineArt 3D as the QuickDraw 3D renderer:
1. Choose Document Preferences in the File menu.
Rendering with FineArt 3D 8



                                                                     
2. Click on the QD3D tab button.

3. Click on the Rendering Engine pop-up menu and select FineArt 3D.

To open FineArt 3D’s Option dialog:
Continuing from step 3 above, click on the Options button.

To render with FineArt 3D:
1. Click OK to close the Document Preferences dialog.

2. Choose Rendering ➜ QuickDraw 3D from the View menu.

Using FineArt 3D with Diehl Graphsoft VectorWorks 8
To render with FineArt 3D:
Choose Rendering ➜ FineArt 3D from the View menu.

To open FineArt 3D’s Options dialog:
View FineArt 3D still selected as the renderer, choose Rendering ➜ FineArt 3D Options
from the View menu.

Using FineArt 3D with MetaCreations Infini-D 4.5
To render a view with FineArt 3D:
1. Select the view you wish to render.

2. Click on the Display command tab in the Command Floater.

3. In the Render area, choose either Flat, Gouraud, or Phong from the left pop-up
menu.

4. Also in the Render area, choose Inklination FineArt 3D from the right pop-up menu.

Infini-D automatically presents FineArt 3D’s options dialog before rendering the current
view.

To use FineArt 3D with Infini-D’s Final Renderer:
1. Choose Render in the File menu.

2. In the Render panel, make the following selections: (1) choose either Flat, Gouraud,
or Phong from the Quality pop-up menu; (2) choose Inklination FineArt 3D from
the Renderer pop-up menu.

3. In the Image panel, choose either Millions, Thousands, or 256 from the Depth pop-
up menu. 

4. Click on either Render or Add to Queue.

Note that the choices mandated in the four steps above are essential to render success-
fully with FineArt 3D. However, the Final Render setup dialog offers more options, such
as for example Output Size, which you can set much as you would for any other type of
rendering.
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Know Issues
1. When rendering with shadows, you must enable backfaces for all the objects in 

the scene. When backfaces are not enabled, Infini-D does not send all the geome-
try to the renderer. The result is partial or missing shadows.

2. Infini-D 4.5 does not keep track of progress correctly when rendering with
FineArt 3D. 

3. If the amount of memory on your Mac allows it, go in the Preferences dialog, click on
the Rendering tab, and set the Block Sizes to Gargantuan (far right). In most cases,
FineArt 3D will render much faster. 

4. When rendering with the final renderer, be sure to follow the recommendation in
Issue 3 above. If Infini-D is allowed to render an image by tiling with smaller bocks of
pixels, incorrect shadows and visible seems may occur. That is because Infini-D tries
to outsmart the renderer by sending it only the objects that are visible within a given
tile. Unfortunately, objects outside the tile may cast shadows. If these objects are not
made available to the renderer, their shadow will be missing. Setting the block size
to Gargantuan insures that Infini-D renders the entire image as a single block of
pixels.

5. You can not use Command-period to interrupt long renderings in Infini-D. However, 
you can switch to another renderer in the middle of a long rendering with 
FineArt 3D just as you would with any other renderer. (You may need to hold the 
mouse down on the renderer popup list for a few seconds.)

Using FineArt 3D with Artifice Design Workshop 1.8
To render with FineArt 3D:
1. Choose Lights & Textures from the View menu to create a shaded rendering.

2. Choose Rendering ➜ Renderer ➜ FineArt 3D from the View menu.

To open FineArt 3D’s Options dialog:
Continuing from step 2 above, choose Rendering ➜ Renderer ➜ Configure Renderer
from the View menu.

Know Issues
The sky and ground backdrops tend to yield poor pen-and-ink renderings, and therefore
should be disabled. To disable them, choose Sun & Shading Settings from the Arrange
menu and deselect Draw Sky Backdrop and Draw Ground Backdrop.

Using FineArt 3D with Vertigo 3D Hot Text 1.5
To select FineArt 3D as the renderer:
1. In the Vertigo 3D HotText window, click on the Scene tab.

2. Choose Fine Art 3D from the Final Render pop-up menu.
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To open FineArt 3D’s Options dialog:
Continuing from step 2 above, click on the Options button.

To render with FineArt 3D:
Click on the Preview button on the left-hand side of the Hot Text window.

Known Issues
Vertigo Hot Text does not support directional lights. Therefore, you will not be able to
render shadows with FineArt 3D.

Using FineArt 3D with Autodessys Form-Z 2.9
To select FineArt 3D as the renderer:
1. Choose Display Options from the Display menu.

2. Click on the QuickDraw 3D Options button.

3. Choose Inklination FineArt 3D from the Rendering Type pop-up menu.

To open FineArt 3D’s Options dialog:
Continuing from step 3 above, click on the Options button.

To render with FineArt 3D:
Choose QuickDraw 3D from the Display menu.

Known Issues
1. Saving the content of the rendering window to an image file does not work well in 

Form-Z 2.9 when rendering with QuickDraw 3D (the problem occurs with any 
QuickDraw 3D renderer, not just FineArt 3D). To save the rendered pen-and-ink 
image, used Grab Image from the edit menu, and paste the image into an image-
editing application such as Adobe Photoshop. 

2. In Form-Z’ QuickDraw 3D Rendering Options dialog, remember to check the Ren-
der Using Smooth Shading option. 

3. Form-Z tends to re-render the content of the window often when QuickDraw 3D is
selected for rendering. With a non-interactive renderer such as FineArt 3D, it can
cause annoying lags and slowdowns. To avoid this problem, remember to switch
back to wireframe rendering once you are done with the pen-and-ink image.
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Fine Art 3D Rendering Options

FineArt 3D is designed to be simple to use. All rendering options are available through
two easy palettes: the Style palette and the Variations palette. Both palettes are accessi-
ble from the Renderer Options dialog.

Anatomy of the Renderer Options Dialog

The main elements of the Options dialog are:

A The Tab buttons – click on one of these tabs to bring up the corresponding palette.

B The palette area – changes according to which tab is clicked. This example shows 
the Styles palette.

C Drag bar – click on this bar to drag the dialog to a different position. (The drag bar 
is only available with some host applications.)

D Apply button – click on this button to confirm the dialog selection and return to 
the host application.

E Cancel button – click on this button to cancel the dialog, discard all the changes, 
and return to the host application.

Styles Panel
The Styles palette offers nine different rendering styles to choose from. The styles vary
from one another by what type of marks – crosshatch or stipple marks – is used for ren-
dering tone values, and whether shading, shadows, and/or outlines are rendered.

A

B

C

D

E
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The styles available in the first column of buttons use crosshatch to generate tone val-
ues. From top to bottom they are: (1) shading only, (2) shadows only, and (3) shading
and shadows. The second column of buttons offers the same options, but using stipple
marks instead of crosshatch for creating tone values. Finally, the third row offers special
styles, which are: (1) outlines only, (2) stipple marks for shading and shadows with no
outlines, and (3) stipple mark for shading and crosshatch for shadows.

Variations on Rendering Styles

The variation palette lets you modify the different rendering styles with options that
affect the weight of the pen used for tracing strokes, the quality of the strokes used for
rendering crosshatch and outlines, the darkness of the outlines, the lighting style, and
the colors used for creating the image. 

Pen weight slider
As its name indicates, this slider affects the weight of the pen use for drawing the
strokes.

Pen thickness samples:

Light Heavy
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Stroke quality slider
This slider controls how much caffeine FineArt 3D consumes before rendering the
image. When set to Mechanical, FineArt 3D is caffeine-free. At the other extreme, when
the slider is set to Sketchy, FineArt 3D consumes at least five cups of caffeine-loaded
java before getting to work.

Outlines slider
This slider affects the darkness of the strokes used for outlining the different shapes in
the 3D scene. 

Lighting styles
The various lighting styles are explained and compared in the following table:

Stroke quality:

Mechanical Sketchy

Outline darkness:

Light Dark

Lighting styles:

This image shows the 3D model rendered with 
a traditional shaded renderer (in this case, 
QuickDraw 3D Interactive).
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Uncorrected
The Uncorrected setting creates an images 
whose tone closely mimics that of the shaded 
rendering.

High contrast
The high-contrast mode brightens light areas 
and darkens dark areas. It is the default light-
ing mode.

Overexposed
This mode brightens light areas and leaves 
dark areas untouched. 

Lighting styles:
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Custom colors
FineArt 3D supports colors other than black and white for the ink and paper.

Creating High-Resolution Pen-and-Ink Images
FineArt 3D is based on Inklination’s FineRes™ technology. This technology offers sev-
eral advantages:

Bright sun
This setting affects only the light that is desig-
nated as the shadow caster, also called the sun. 
It effectively boosts the intensity of the sun, so 
that any surface that is exposed to it becomes 
washed out. It is useful for special effects and 
architectural rendering.

To use custom colors:

First check the Use custom colors box. Then, 
click on each color swatch to choose custom 
colors for the ink and paper.

All subsequent renderings will use the selected 
colors. To return to black-and-white rendering, 
simply check-off the Use custom colors box.

Lighting styles:
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1. Images rendered with FineRes™ look consistent at all resolutions. When rendered at 
high-resolutions – 300 dot per inch and above – images are crisp and closely resem-
ble what you get on-screen.

2. Rendering large high-resolution images uses less memory with FineRes™.

3. Finally, rendering large high-resolution images is faster with FineRes™.

FineArt 3D can only take advantage of FineRes™ when the host application has been
updated to support it. Fortunately, it takes relatively little effort to make use of it, and
we expect that application developers will update their products quickly.

What to do if your host application does not support FineRes™
As of January 27, 1999, Microspot has implemented FineRes™ in 3D World 3.1 due out
later in 1999. If you are using a different host application, that does not yet support
FineRes™, let the manufacturer of that product know that you would like them to take
advantage of this technology.

Alternately, with some applications, you can use the Alternate Rendering Resolution
feature available in the Expert Panel. This feature is described in detail in the next chap-
ter.

Inklination’s FineRes™ technology provides consistent results at all resolutions.
The image on the left shows the original rendering as it appears on-screen. The
image on the right shows the same image rendered at 600 dpi. (Note: you need to
print this page to better appreciate the quality of the 600 dpi image.)
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Expert Options: Rendering High-Resolution Images

Alternate Rendering Resolution (ARR)

The Alternate Rendering Resolution (ARR) feature, found in the Expert panel, provides
a way to generate high-resolution pen-and-ink images from some host applications that
do no support Inklination’s FineRes technology. Using this feature successfully requires
some care; you must manually synchronize the resolution at which the application
thinks it is rendering, with the resolution at which FineArt 3D is actually rendering1.
However, it is well worth the effort.

In most cases, using ARR involves three main steps:

1. Select an image or printing resolution in the host application.

2. Set the Alternate Rendering Resolution in FineArt 3D to the same value.

3. Activate ARR when generating the image.

This process is explained in more details, for each application, in the following sections.

Printing high-resolution images with VectorWorks 8
To setup VectorWorks and FineArt 3D for high-resolution printing:

1. Applications that support FineRes do this automatically.

1. Choose Preferences ➜ Document Preferences 
from the File menu. In the resulting dialog, 
select the QD3D panel. Set the printing resolu-
tion as desired (in this example, 400 dpi).
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To print the content of a window into a high-resolution pen-and-ink image:

Important notes
1. This method only works if the entire printout fits on a single sheet of paper.

2. This method does not work for exporting high-resolution images to files.

3. You do not have to wait for the rendering to be completed in Step 5. Instead, you can
interrupt the rendering with Command-’.’. You will end up with a blank window. Pro-
ceeding to Step 6 will print the correct image.

Creating high-resolution images with Design Workshop 1.8
Design Workshop does not support the concept of resolution directly. Yet, it is possible
to create high-resolution images with the help of an image-editing application such as
Adobe Photoshop. Here’s how it works:

2. Still within the QD3D panel, choose 
FineArt 3D from the Rendering Engine popup 
menu. Then, click the Engine Options button 
to bring up FineArt 3D’s rendering options dia-
log. 

3. Click on the Expert tab to bring up the Expert 
panel. Set the Alternate Rendering Resolution 
to the same printing resolution you chose in 
Step 1 above.

4. Close FineArt 3D’s dialog by clicking on the Apply button, and VectorWorks’ 
Document Preferences dialog by clicking on the OK button.

5. First, you must render the window in pen and ink. To do so, select FineArt 3D 
from the View ➜ Rendering menu. 

6. Once rendering in pen and ink is done, you are ready to print it. Choose Print 
from the File menu.

7. In the Print dialog, select all the print options as you would normally do. Press 
and hold the Command and Shift keys, and click on the Print button. Hold the 
two keys down until you hear two beeps; they signal that FineArt 3D is using the 
Alternate Rendering Resolution for rendering the image.
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1. Bring up FineArt 3D’s Options dialog (see Sec-
tion “Using FineArt 3D with Artifice Design 
Workshop 1.8” on page 10,) go to the Expert 
panel by clicking on the Expert tab, and set the 
Alternate Rendering Resolution to the desired 
resolution, in this example 400 dpi.

2. Render the content of the window with FineArt 3D as described in “Using 
FineArt 3D with Artifice Design Workshop 1.8” on page 10.

3. To create a high-resolution picture file, choose Export 2D ➜ Pixel Image from 
the File menu. 

4. Select the Reduce or Enlarge radio button. In 
the corresponding text field, enter the value 

 where R is the Alternate Rendering 
Resolution that you chose in Step 1. In this 
example, we set the text field to 

.

5. Press and hold down the Command and Shift keys, and click on the Export but-
ton. Keep holding the two keys down until your hear two beeps; they signal that 
FineArt 3D has accepted the Alternate Rendering Resolution. (If you get an alert 
box asking whether you wish to replace an existing file, keep holding Command 
and Shift down has you click Replace.)

6. The image file that you created in Step 5 contains a high-resolution image. How-
ever, Design Workshop labeled it as a 72 dpi image (screen resolution). To 
ensure that it prints properly, you must open it in an image-editing application, 
such as Adobe Photoshop, and set its resolution to the resolution chosen in 
Step 1.

100 75× ( )R

100 400 75 533× =( )
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Creating high-resolution images with HotText 1.5

Vertigo Hot Text lends itself very well to the use of Alternate Rendering Resolution. For
instance, the “FineArt 3D” 3D text above was created with Hot Text. Here’s how to do it:

MiniCad 7, Form-Z, and Infini-D 4.5
Alternate Rendering Resolution can not be used with these applications.

About Resolution and Style
The resolution that you are using affects the style of the pen-and-ink rendering to some
extent. At resolutions below 288 dpi, FineArt 3D generates images that have a soft look,
much like renderings on screen. At resolutions at or above 288 dpi, FineArt 3D switches
to a crisp pen-and-ink look. Here’s an example:

1. Bring up FineArt 3D’s options dialog (see “Using 
FineArt 3D with Vertigo 3D Hot Text 1.5” on page 10), 
and go to the Expert panel. Set the Alternate Render-
ing Resolution to the resolution of the Photoshop docu-
ment you are working with (in this example 400 dpi)

2. Setup and preview the Hot Text effects as you normally would.

3. When you are ready to apply the filter, press and hold the Command and 
Shift keys, and click on the OK button. Hold the two keys down until you 
hear two beeps; they signal that FineArt 3D has accepted the Alternate Ren-
dering Resolution. That’s all there is to it!
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Setting Up 3D Models for Rendering with FineArt 3D

Avoid Using Complex Textures
FineArt 3D currently does not support complex textures such are those that are typi-
cally used to depict wood, bricks, marbles, and other patterns. Instead, FineArt 3D uses
the diffuse colors1 assigned to the various objects in the scene when evaluating the tonal
values. When a complex texture is assigned to an object, it may mask an underlying dif-
fuse color that looks completely different. Therefore, to achieve predictable results, we
recommend that only simple colors, without textures, be assigned to the objects in the
scene.

Assign Distinct Colors to Different Objects
To draw the delicate outline strokes that contribute greatly to the elegance of its render-
ings, FineArt 3D builds an internal representation of the various objects in the scene. In
some cases, it must do so from a simple stream of triangular facets coming from the host
application. One important clue that it uses, to determine which facet belongs to which
object, is the colors of the facets. Assigning different colors to the various objects helps
FineArt 3D to distinguish these objects.

Choose One Directional Light to Cast Shadows
FineArt 3D supports ambient, point, spot, and directional2 light sources. However, it will
only compute shadows from a single directional light. When rendering shadows, to
achieve consistent results we recommend that you turn shadow casting on for one direc-
tional light, and turn shadow casting off for all other light sources.

1. Diffuse colors are also often referred to as Flat, Plastic, Simple, or Surface colors.
2. Directional light sources are sometimes also referred to as Distant, or Parallel lights, or 

simply Sun.
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Tips and Troubleshooting

Tip: Improving the rendering speed
In designing FineArt 3D, we have chosen to emphasize the rendering quality over the
rendering speed. A consequence of this choice is that very complex 3D models can take
a while to render. Here’s a few suggestions that may help you deal with this issue:

• Try to keep your 3D model as simple as possible. For instance, if there are a lot of 
small objects that are hidden behind larger ones, delete them. 

• Likewise, while making adjustments in preparation for the final rendering, consider-
ing simplifying the 3D model by hiding all non-essential objects, if the host applica-
tion allows it. 

• Choose a rendering style that does not use shadows, at least until you are ready to 
create the final rendering. Shadows can more than double the rendering time.

• If possible, enable back-face removal (also called back-face culling). 
• Render into smaller windows.

Tip: rendering small images
If you need to generate a very small image, for instance to fit in a narrow column of text,
you may find advantageous to first render it into a larger window. Then use an image
editing application, such as Adobe Photoshop, to reduce it to its final size. There are at
least two reasons to do it this way:

• Many applications limit the smallest window size that you can get.
• With a larger window, it is easier to preview the rendering.

In this case, you may find that using Medium or even Thick for the Pen Thickness (see
“Variations on Rendering Styles” on page 13) yields better looking strokes after reduc-
tion.

Tip: preview with the QuickDraw 3D Interactive renderer
If you have a choice of renderer for previewing the 3D model, you may find that the
QuickDraw 3D’s Interactive renderer yields tone values that most closely match
FineArt 3D’s rendering style. That is not a coincidence; FineArt 3D was designed that
way. Other renderers, because of difference in the way they compute illuminations, may
not work as well to help you setup the light sources in the scene.

Tip: cancelling long rendering
With most host applications, a long rendering can be cancelled by pressing the Com-
mand and Period keys simultaneously. You may need to hold the keys down a few sec-
onds before it takes effect.
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Problem: frequent blank renderings
If you frequently get a blank window when rendering with FineArt 3D, you are probably
running out of memory. (FineArt 3D dutifully report such errors to the host application.
However, many applications simply ignore these errors instead of reporting them to the
user.) There are a number of things you can do to work around this problem:

• Choose a rendering style that does not include shadows. Rendering shadows can as 
much as double the amount of memory required.

• Render into a smaller window.
• Quit all other active applications to free memory.
• Assign less memory to the host application.

The last recommendation may seem counterintuitive. Since version 1.1, FineArt 3D
uses temporary memory for most of its memory needs. Temporary memory refers to
memory that is used neither by the Mac OS nor by any currently running application.
By diminishing the amount of memory allocated to the host application, more tempo-
rary memory is made available, thus increasing the chance that FineArt 3D will be able
to complete the rendering.

Problem: incorrect shadows or no shadow
FineArt 3D supports shadow-casting from a single directional light source. (Such lights
are also frequently referred to as distant lights, parallel lights, or simply Sun.) If there
are several directional lights that cast shadows in your 3D model, FineArt 3D will only
use one of them. To get consistent results, it is recommended that you turn off shadow
casting for all but one directional light.

Furthermore, note that you will not be able to get shadows with applications that do not
provide directional light sources, such as Vertigo HotText.

Problem: incorrect outlines with MiniCad and VectorWorks 
Sometimes additional outline edges may appear with Minicad and VectorWorks. They
are caused by so called cracks in the geometry. For instance, they often appear above
and below window opening in walls.

These cracks result from the way these two applications prepare the model before send-
ing it to QuickDraw 3D for rendering. They are not exclusive to FineArt 3D; these cracks
sometimes also cause artifacts with other renderers. But FineArt 3D is much more sen-
sitive to them. 

Unfortunately, there is nothing we can do at the level of the renderer to address this
problem. To alleviate, or sometimes even eliminate the problem completely, you can try
to use an axonometric projection, rather than a perspective projection.
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Software License and Limited Warranty

Please read this license agreement carefully before installing or using the software. By
using the software, you are agreeing to be bound by the terms of this license. If you do
not agree to the terms of this license, do not install or use the software, and delete the
software and all related files from your computer. 

1.  License and Proprietary Rights. (a) The software, artwork, music, and other compo-
nents included in this computer program (the “Software”) are the copyrighted property
of Inklination, Inc. and its licensors (collectively referred to as “Inklination”). The Soft-
ware is licensed (not sold) to you, and Inklination owns all copyright, trade secret,
patent and other proprietary rights in the Software. Until you have purchased a license
for single, multiple, or site license use of the Software, this Software may be used as a
demo in the form provided only, and subject to the terms in sections 2 through 6 below.
Once you have purchased a license to unlock the Software for full single, multiple, or
site use, the license is subject to the following terms (as may be applicable to the type of
license purchased) in addition to the terms of sections 2 through 6.

(b) Single User License: If you purchased a single user license to the Software, you may
use the Software on a single computer. You may not: (i) copy the Software other than
once for back-up purposes; or (ii) transmit the Software over a network, by telephone,
or electronically using any means.

(c) Multiple User License: If you purchased a multiple user license to the Software, you
may: (i) Use or, if a single copy of the Software or Software registration key is provided,
make copies of the Software up to the number of copies for which you have paid, pro-
vided all copyright and proprietary notices on the original Software are included on
duplicate copies; (ii) Make one backup copy of the Software for archival purposes only,
provided all copyright and proprietary notices on the Software are included on such
copy; and (iii) Make copies of all documentation provided with the Software up to the
number of copies for which you have paid, provided all copyright and proprietary
notices on the documentation are included on duplicate copies. You may not transmit
the Software over a network, by telephone, or electronically using any means.

(d) Site License: If you purchased a site license to the Software, you may: (i) Use or
make copies of the Software solely for use on computers at the Site (as defined herein),
provided all copyright and proprietary notices on the original Software are included on
duplicate copies and provided such copies are used only at the Site; (ii) Make one
backup copy of the Software for archival purposes only, provided all copyright and pro-
prietary notices on the Software are included on such copy; (iii) Make copies of all doc-
umentation provided with the Software, provided all copyright and proprietary notices
on the documentation are included on duplicate copies and provided such copies are
used only at the Site; (iv) Use the Software over a network at the Site, solely for comput-
ers located at the Site; (v) For purposes of this section, “Site” is defined as a single build-
ing.
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2.  All Licenses are subject to the following additional terms: You may not: (i) distribute
to any third party, rent, lease or sublicense all or any portion of the Software; (ii) modify
or prepare derivative works of the Software; or (ii) reverse engineer, decompile or disas-
semble the Software. You may transfer the Software, but only if the recipient agrees to
accept the terms and conditions of this Agreement. If you transfer the Software, you
must transfer all components and documentation and erase any copies residing on com-
puter equipment. Your license is automatically terminated if you transfer the Software. 

3.  Disclaimer of Warranties. You expressly acknowledge and agree that use of the Soft-
ware is at your sole risk. The Software and any related documentation or materials are
provided “AS IS” and without warranty of any kind. INKLINATION EXPRESSLY DIS-
CLAIMS ALL WARRANTIES, EXPRESS AND IMPLIED, INCLUDING, BUT NOT LIM-
ITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NONINFRINGEMENT. INKLINATION DOES NOT WAR-
RANT THAT THE FUNCTIONS CONTAINED IN THE SOFTWARE WILL MEET YOUR
REQUIREMENTS, OR THAT THE OPERATION OF THE SOFTWARE WILL BE UNIN-
TERRUPTED OR ERROR-FREE, OR THAT DEFECTS IN THE SOFTWARE WILL BE
CORRECTED. THE ENTIRE RISK AS TO THE RESULTS AND PERFORMANCE OF THE
SOFTWARE IS ASSUMED BY YOU. SOME JURISDICTIONS DO NOT ALLOW THE
EXCLUSION OF IMPLIED WARRANTIES, SO THE ABOVE EXCLUSION MAY NOT
APPLY TO YOU. 

4.  Limitation of Liability. UNDER NO CIRCUMSTANCES INCLUDING NEGLIGENCE
SHALL INKLINATION, OR ITS DIRECTORS, OFFICERS, EMPLOYEES OR AGENTS, BE
LIABLE TO YOU FOR ANY INCIDENTAL, INDIRECT, SPECIAL OR CONSEQUENTIAL
DAMAGES (INCLUDING DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS
INTERRUPTION, LOSS OF BUSINESS INFORMATION, AND THE LIKE) ARISING OUT
OF THE POSSESSION, USE, OR MALFUNCTION OF THIS PRODUCT, INCLUDING
WITHOUT LIMITATION, DAMAGE TO PROPERTY AND, TO THE EXTENT PERMIT-
TED BY LAW, DAMAGES FOR PERSONAL INJURY, EVEN IF INKLINATION OR AN
INKLINATION AUTHORIZED REPRESENTATIVE HAS BEEN ADVISED OF THE POSSI-
BILITY OF SUCH DAMAGES. SOME JURISDICTIONS DO NOT ALLOW THE LIMITA-
TION OR EXCLUSION OF LIABILITY FOR INCIDENTAL OR CONSEQUENTIAL
DAMAGES, SO THE ABOVE LIMITATION OR EXCLUSION MAY NOT APPLY TO YOU.
YOU AGREE THAT THE LIABILITY OF INKLINATION ARISING OUT OF ANY KIND OF
LEGAL CLAIM (WHETHER IN CONTRACT, TORT, OR OTHERWISE) WILL NOT
EXCEED THE AMOUNT YOU ORIGINALLY PAID FOR THE USE OF THIS PRODUCT.

5.  Government End Users. If you are acquiring the Software on behalf of any unit or
agency of the United States Government, the following provisions apply. The Govern-
ment agrees:

(a) If the Software is supplied to the Department of Defense (“DoD”), the Software is
classified as “Commercial Computer Software” and the Government is acquiring only
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“restricted rights” in the Software and its documentation as that term is defined in
Clause 252.227-7013(c)(1) of the DFARS; and

(b) If the Software is supplied to any unit or agency of the United States Government
other than DoD, the Government's rights in the Software and documentation will be as
defined in Clause 52.227-19(c)(2) of the FAR or, in the case of NASA, in Clause 18-
52.227-86(d) of the NASA Supplement to the FAR.

6.  General. This license agreement is effective until terminated, cannot be assigned or
transferred and is governed by the laws of the state of Washington and of the United
States of America applicable therein (without reference to choice of laws). If for any rea-
son a court of competent jurisdiction finds any provision of this license agreement or
portion thereof, to be unenforceable, that provision of this license agreement shall be
enforced to the maximum extent permissible so as to effect the intent of the parties, and
the remainder of this license agreement shall continue in full force and effect. This
license agreement and your right to use the Software shall immediately terminate if you
fail to comply with any of the terms of this license agreement. Upon termination you
must immediately destroy all originals and copies of the Software, or return them to
Inklination. This license agreement sets forth the entire agreement and understanding
of the parties relating to this subject matter. No amendment or modification of this
license agreement shall be effective unless in writing signed by both parties.
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